karlley's tech blog

学習メモや記録とか

2022-06-29から1日間の記事一覧

rails s でPlease run rails webpacker:install と表示されて起動しない

Railsの教科書の手順で進めていましたがrails sでアプリが起動しなかったので調べてみました。 結論 node.jsをインストールしてwebpaderをインストールする。 環境 macOS 12.3.1 ruby 3.0.3 Rails 6.1.6 Railsの必要rubyバージョンの確認 下記ページでrails …

バージョン指定してrails new

最新のrails7系ではなくrails6系でrails new したかったのでバージョン指定する手順を調べました。 結論 指定したいRailsをgem経由でインストール rails _バージョン_ new アプリ名 でバージョンを指定してnewする インストールされているrails gemのバージ…